29.06.2022

Релиз десктоп-окружения Trinity R14.0.12, продолжающего развитие KDE 3.5

Опубликован релиз десктоп-окружения Trinity R14.0.12, продолжающего развитие кодовой базы KDE 3.5.x и Qt 3. Бинарные пакеты в ближайшее время будут подготовлены для Ubuntu, Debian, RHEL/CentOS, Fedora, openSUSE и других дистрибутивов.

Из особенностей Trinity можно отметить собственные средства для управления параметрами экрана, основанная на udev прослойка для работы с оборудованием, новый интерфейс для настройки оборудования, переход на композитный менеджер Compton-TDE (форк Compton с расширениями TDE), улучшенный конфигуратор сети и механизмы аутентификации пользователей. Окружение Trinity может быть установлено и использовано одновременно с более актуальными выпусками KDE, в том числе предоставлена возможность использования в Trinity уже установленных в системе KDE-приложений. Также присутствуют средства для корректного отображения интерфейса GTK-программ без нарушения единого стиля оформления.

Среди добавленных улучшений:

  • Реализована поддержка PolicyKit. Добавлен DBus-сервис Polkit-agent-tde, предоставляющий агент аутентификации для Polkit, используемый для аутентификации сеанса пользователя в Trinity. Для разработчиков приложений подготовлена библиотека Polkit-tqt, позволяющая использовать API PolicyKit через интерфейс в стиле TQt.
  • Добавлено приложение tdemarkdown для просмотра документов в формате Markdown.
  • Улучшен эмулятор терминала Konsole, добавлена опция для управления прозрачностью.
  • В Quanta, интегрированной среде для web-разработки, появилась поддержка HTML 5. В редакторе VPL добавлена поддержка сложных символов (например, с надстрочными символами) и немых клавиш.
  • В KSSL добавлена поддержка сертификатов Let’s Encrypt.
  • В Kxkb реализован прозрачный фон для метки в системном лотке.
  • В Sip4-tqt добавлена начальная поддержка Python 3.
  • Улучшено взаимодействие между tdm и plymouth.
  • В Tdebase добавлена возможность установки профилей ICC.
  • Продолжен перевод пакетов на систему сборки CMake. Требования к минимальной версии CMake подняты до 3.1. В некоторых пакетах прекращена поддержка automake.
  • В коде разрешено использование возможностей из стандарта C++11.
  • Добавлена поддержка Ubuntu 22.04. Улучшена поддержка Gentoo Linux. Прекращена поддержка Debian 8.0 и Ubuntu 14.04.



Источник.