26.09.2020

Уязвимость в Bluetooth-стеке Bluez


В свободном Bluetooth-стеке BlueZ, который используется в дистрибутивах Linux и Chrome OS, выявлена уязвимость (CVE-2020-0556), потенциально позволяющая злоумышленнику получить доступ к системе. Из-за некорректной проверки доступа в реализации Bluetooth-профилей HID и HOGP уязвимость позволяет без прохождения процедуры привязки устройства к хосту добиться отказа в обслуживании или повышения своих привилегий при подсоединении вредоносного Bluetooth-устройства. Вредоносное Bluetooth-устройство, без прохождения процедуры сопряжения, может выдать себя за другое HID-устройство (клавиатура, мышь, игровые контроллеры и т.п.) или организовать скрытую подстановку данных в подсистему ввода.

По данным компании Intel проблема проявляется в выпусках Bluez до 5.52 включительно. Непонятно, затрагивает ли проблема выпуск 5.53, который не анонсирован публично, но с февраля доступен через Git и в архиве сборок. Патчи с исправлением (1, 2) уязвимости предложены 10 марта, а выпуск 5.23 был сформирован 15 февраля. В дистрибутивах обновления пока не сформированы (Debian, Ubuntu, SUSE, RHEL, Arch, Fedora).

Источник: https://www.opennet.ru/opennews/art.shtml?num=52542

Добавить комментарий