28.11.2021

Новые версии Samba 4.14.4, 4.13.8 и 4.12.15 с устранением уязвимости

Подготовлены корректирующие выпуски пакета Samba 4.14.4, 4.13.8 и 4.12.15 с устранением уязвимости (CVE-2021-20254), которая в большинстве случаев может привести к краху процесса smbd, но в наихудшем сценарии не исключается возможность неавторизированного доступа к файлам и удаления непривилегированным пользователем файлов на сетевом разделе.

Уязвимость вызвана ошибкой в функции sids_to_unixids(), приводящей к чтению данных из области за границей буфера при преобразовании идентификаторов групп SID (Windows Security Identifier) в GID (Unix Group ID). Проблема возникает в случае добавления отрицательного элемента в кэш сопоставлений SID в GID. Разработчики Samba не смогли выявить надёжные и повторяемые условия для проявления уязвимости, но выявивший уязвимость исследователь считает, что проблема может быть эксплуатирована для удаления файлов на файловом сервере без должных прав на выполнение данной операции.

Источник.