24.11.2020

Критическая уязвимость в системе управления контентом Drupal


В системе управления контентом Drupal выявлена критическая уязвимость (CVE-2020-13671), позволяющая удалённо выполнить произвольный PHP код на сервере. Уязвимости присвоен критический уровень опасности. Проблема устранена в выпусках Drupal 7.74, 8.9.9, 8.8.11 и 9.0.8.

Уязвимость вызвана некорректной проверкой двойных расширений при загрузке файлов на сервер, что позволяет загрузить файл вида filename.php.txt, который в определённых серверных конфигурациях при обращении будет выполнен как PHP-код. Из опасных расширений, для которых неверно может быть обработан MIME-тип, отмечены phar, php, pl, py, cgi, asp, js, html, htm и phtml.

Источник: https://www.opennet.ru/opennews/art.shtml?num=54127

Добавить комментарий