25.09.2020

Уязвимость в Ghostscript, позволяющая выполнить код при открытии PostScript-документа


В Ghostscript, наборе инструментов для обработки, преобразования и генерации документов в форматах PostScript и PDF, выявлена уязвимость (CVE-2020-15900), которая может привести к изменению файлов и запуску произвольных команд при открытии специально оформленных документов в формате PostScript. Использование в документе нестандартного PostScript-оператора rsearch позволяет вызвать переполнение типа uint32_t при вычислении размера, переписать области памяти вне выделенного буфера и получить доступ к файлам в ФС, что можно использовать для организации атаки для выполнения произвольного кода в системе (например, через добавление команд в ~/.bashrc или ~/.profile).

Проблема затрагивает выпуски с 9.50 по 9.52 (ошибка присутствует начиная с выпуска 9.28rc1, но, по данным выявивших уязвимость исследователей, проявляется с версии 9.50). Исправление предложено в выпуске 9.52.1 (патч). Обновления пакетов с исправлением уже выпущены для Debian, Ubuntu, SUSE. Пакеты в RHEL проблемы не подвержены.

Напомним, что уязвимости в Ghostscript представляют повышенную опасность, так как данный пакет используется во многих популярных приложениях для обработки форматов PostScript и PDF. Например, Ghostscript вызывается в процессе создания миниатюр на рабочем столе, при фоновой индексации данных и при преобразовании изображений. Для успешной атаки во многих случаях достаточно просто загрузить файл с эксплоитом или просмотреть каталог с ним в Nautilus. Уязвимости в Ghostscript также можно эксплуатировать через обработчики изображений на базе пакетов ImageMagick и GraphicsMagick, передав в них JPEG или PNG-файл, в котором вместо картинки находится код PostScript (такой файл будет обработан в Ghostscript, так как MIME-тип распознаётся по содержимому, а не полагаясь на расширение).

Источник: https://www.opennet.ru/opennews/art.shtml?num=53480

Добавить комментарий