28.02.2024

Уязвимость в утилите GNU split, приводящая к переполнению буфера

В утилите split, поставляемой в пакете GNU coreutils и применяемой для разделения больших файлов на части, выявлена уязвимость (CVE-2024-0684), приводящая к переполнению буфера при обработке длинных строк (несколько сотен байт), в случае использования в split опции «—line-bytes» («-C»). Уязвимость была выявлена в ходе анализа сбоев, возникающих при использовании утилиты split для разделения данных, передаваемых при помощи QR-кодов.

Уязвимость вызвана ошибкой, допущенной в выпуске coreutils 7.2 при замене вызова функции xrealloc на xpalloc. Патч с исправлением уже принят в кодовую базу, но новая версия с исправлением пока не сформирована. Для демонстрации проявления уязвимости опубликован пример файла, вызывающего переполнение при запуске «split -C 1024 ./split_me».

Источник: https://www.opennet.ru/opennews/art.shtml?num=60490 Источник.