22.04.2024

Обновление OpenWrt 22.03.5 и 21.02.7

Опубликовано обновление дистрибутива OpenWrt 22.03.5 (выпуск 22.03.4 был пропущен), ориентированного на применение в различных сетевых устройствах, таких как маршрутизаторы, коммутаторы и точки доступа. OpenWrt поддерживает множество различных платформ и архитектур и обладает системой сборки, позволяющей просто и удобно производить кросс-компиляцию, включая в состав сборки различные компоненты, что позволяет легко сформировать адаптированную под конкретные задачи готовую прошивку или образ диска с желаемым набором предустановленных пакетов. Сборки сформированы для 35 целевых платформ.

Основные изменения в OpenWrt 22.03.5:

  • Добавлена поддержка устройств Watchguard Firebox T10, Asus RX-AX53U, Mercusys MR70X, D-Link DAP-X1860 A1 и TP-Link Archer AX23 v1.
  • Для устройства Aruba AP-105 подготовлен загрузочный образ, совместимый с APBoot.
  • Для устройств Archer AX23 / MR70X до 25 MHz уменьшена частота SPI.
  • Устранено зацикливание при загрузке Buffalo WSR-600DHP.
  • Исправлена ошибка в UBI (Unsorted Block Images), мешавшая загрузке на некоторых устройствах.
  • Добавлена поддержка модемов Mikrotik R11e-LTE6.
  • Предоставлены пакеты с поддержкой LTE для маршрутизатора GL-XE300.
  • Налажена работа USB на маршрутизаторе GL-AR300M.
  • Пакет ccache обновлён до версии 4.6.3. Налажена компиляция с использованием ccache и GCC 13.
  • uclient обновлён до версии 2023-04-13.
  • Ядро Linux обновлено до версии 5.10.176.
  • В tplink-safeloade добавлена поддержка загрузки прошивок для TP-Link Archer AX23 v1 и Mercusys MR70X.
  • Добавлена поддержка Flash-памяти XMC XM25QH64C.
  • В imagebuilder разрешено указание размера корневого раздела (ROOTFS_PARTSIZE).
  • Устранены неопасные уязвимости CVE-2023-0464 и CVE-2023-0465 в OpenSSL, связанные с обработкой политик для сертификатов. Устранена уязвимость MacStealer (CVE-2022-47522) в беспроводном стеке. Устранены уязвимости в модулей ядра ksmbd с реализацией файлового сервера на базе протокола SMB.

Одновременно сформировано обновление прошлой ветки OpenWrt 21.02.7, в котором устранены уязвимости в OpenSSL и исправлена ошибка в UBI (Unsorted Block Images), мешавшая загрузке на некоторых устройствах.

Источник: https://www.opennet.ru/opennews/art.shtml?num=59080 Источник.